Samsung Galaxy Tab 4 Android 4.4.2 can't download gaia?

Answered

Comments

1 comment

  • Avatar
    Jim Margolis

    @Edward

    Gaia GPS requires Android 6 or higher.  You can use your account on multiple devices, so you won't need to get a separate subscription for a new device.

    If you have any further questions, please contact Support here.

    0
    Comment actions Permalink

Post is closed for comments.