Course-Up mode very unresponsive

Comments

18 comments

  • Avatar
    RocketMan

    I used the app for my first time today, on my iPad, while driving off road and saw similar behavior.  I had Course Up turned on and track recording turned on.  The tip of the track recording trace would keep up with my position on the map but the position arrow would lag behind.  It was frustrating when I was looking for a turn and I would physically come to the turn long before the arrow was there.  Clearly the built in GPS in the iPad was giving a good position since the track recording trace was keeping up with actual position.

    0
    Comment actions Permalink
  • Avatar
    Lee

    I have the same issue on my iPad mini 5.  It tracks smoothly in all modes other than Course Up.  I even bought an external  GPS receiver thinking the built in GPS of iPad was not able to keep up.  That was before I realized it worked outside of Course Up.  Anyone know a fix?

     

     

     

     

     

     

    a

    0
    Comment actions Permalink
  • Avatar
    Jim Margolis

    Hello all, 

    I'm just popping in to let you know that we have a bug report open for this issue and we're looking into a fix. 

    In the meantime, please make sure that your location permissions are set to "Always" by following these steps:

    Also, closing any other apps running in the background while using Gaia GPS may help. 

    We'll update this thread as soon as we have an update. 

    0
    Comment actions Permalink
  • Avatar
    Edmond

    I deleted and reinstalled the app and that seems to have improved things for me for the time being at least. You might want to give that a try while Gaia works on fixing the bug. 

    1
    Comment actions Permalink
  • Avatar
    anton

    Same issue here, with my iPad Mini. The red line advances properly, but the arrow lags WAY behind and the map centers on the arrow. So I am basically driving off the map constantly, making Course mode totally useless for seeing upcoming turns.

    In Compass mode, the responsiveness is fine but its far less suited to driving.

    We used this app all day every day in Baja two years ago and it was flawless. Something has changed for the worse. i'd be happy to be able to reload the two year old version if it was made available.

    1
    Comment actions Permalink
  • Avatar
    gabrielamadeus

    I've got the same problem, long time Gaia user and it's super frustrating. 

    0
    Comment actions Permalink
  • Avatar
    Steven

    Having the same problem on the mini 5. Makes the software unuseable.

    0
    Comment actions Permalink
  • Avatar
    gabrielamadeus

    Pretty unbelievable this hasn't been resolved yet. It's a downright dangerous navigation glitch. 

    0
    Comment actions Permalink
  • Avatar
    Kennyv

    Yikes. A year later and not fixed. I’m still having issues. I’m sending in another ticket. Please please make this a priority Gaia.

    0
    Comment actions Permalink
  • Avatar
    TucsonJoe

    Is there a resolution for this issue yet??

    0
    Comment actions Permalink
  • Avatar
    Kennyv

    Mine is working great for the past several months now. I’m not sure if it was an IOS update or a Gaia but all good for me.

    0
    Comment actions Permalink
  • Avatar
    Jim Margolis

    @TucsonJoe
     
    We are still working on fixing this issue, sorry about that.  
     
    If you have any further questions, please contact Support here.

    0
    Comment actions Permalink
  • Avatar
    Anonymous User

    Still seeing this issue (version 2022.4, iPhone 12 mini, IOS 15.4.1). Do you have an estimate by when you'll be able to address the issue or more background information what causes it?

    0
    Comment actions Permalink
  • Avatar
    smithfalsettidesigns

    Have been using Gaia since august 2021, course up worked great then a couple of months ago the course up developed this problem. Planned a callback and told me it was being worked on, then a week later it started to work perfectly, great I thought Gaia must have found the problem
    Then last week they sent out this new map layer (beta) setting, intermittent course up came back even worse, turned off the beta layer (which is useless by the way) restated the program still bad, I completely deleted the app this morning and reinstalled in hope that it will work, I downloaded a free trial of OnX and it is starting to look very attractive as it works well!!!

    0
    Comment actions Permalink
  • Avatar
    Kennyv

    For me, course up and recording works as it should 90% of the time. I’ve altered settings/reinstalled etc. I’ve found nothing that makes a difference. I still like Gaia over all others.

    Again, asking tech support to fix this. Thank you.

    0
    Comment actions Permalink
  • Avatar
    ncicale25

    I'm having the same issue with this KEY piece of functionality. I use this to follow motorcycle off-road tracks, and not having the map always up is super frustrating. As others on this thread have commented, the map stops following my progress as soon as I tap on that icon. Compass mode works fine. 

    0
    Comment actions Permalink
  • Avatar
    gabrielamadeus

    Two years since the bug report was initially submitted and still no solution, sheesh! 

    0
    Comment actions Permalink
  • Avatar
    smithfalsettidesigns

    Went out yesterday and used my phone instead of my Ipad and now the phone is showing the same problem, wish this would get worked out, purchased Onx and it is starting to look more attractive as it works!!

    0
    Comment actions Permalink

Please sign in to leave a comment.