Anyone else having GPS tracking issues lately?

Comments

17 comments

  • Avatar
    zcamp54657

    Yes, very frustrating. Started experiencing the issue on 1/20/24 and has been going on since then.

    3
    Comment actions Permalink
  • Avatar
    gosebubbe

    At least it's not just me then, thats some comfort.

    My next hike/ride I'll try and track simultaneously with Strava and see if it's really a Gaia issue (which I suspect) or not.

    1
    Comment actions Permalink
  • Avatar
    gosebubbe

    Did a ride today and tracked it with both Gaia and Strava.

    Though it wasnt as bad as some other times, the track had one straight line, instead of following the trail, indicating some GPS issues.

    However, it tracked just fine in Strava, where the track followed the trail and was roughly 0.5miles longer, in total.

    So, this doesnt seem to be a phone or GPS issue, as it works just fine in Strava...

    1
    Comment actions Permalink
  • Avatar
    gosebubbe

    Today's ride was an utter failure. In 40 mins, gaia managed to record 0.6 miles of the ~4 ridden.

    I'm done with Gaia. I really dislike Strava, but if Gaia cant make key features work, I don't have much of a choice.

    1
    Comment actions Permalink
  • Avatar
    ktdoan98

    The "straight line" tracking is what happens for me in power saving mode. I think there has been some changes (but could be Android updates) which now I have to change to allow Gaia to run in the background.

    0
    Comment actions Permalink
  • Avatar
    bill.landman.2

    I've been fighting the same issue for at least a month. I've set the permissions on my Samsung S23 correctly, allowing Gaia access to Location, turning off "pause activity of unused".

    1
    Comment actions Permalink
  • Avatar
    gosebubbe

    @bill: Same here. Until the issue gets fixed, Im going to have to use Strava, even though I really dislike their UI, but Ive done a few rides now and have not seen any of the same issues there.

    0
    Comment actions Permalink
  • Avatar
    rob.bond

    I have noticed this too, and thought it was related to my switch to a mid-level Galaxy A54, but if the S23 is having problems, them perhaps it is a Gaia GPS issue. I actually recently brought a dedicated multi-band/multi-GNSS receiver (Garmin GPSMAP 65s) as my Gaia GPS tracks had gotten so bad. 

    0
    Comment actions Permalink
  • Avatar
    gosebubbe

    @rob: Pretty much every single ride for 4-5w that I tracked with Gaia had issues. Every single ride since then, and  a few I doubled on at the end, have tracked 100% in Strava.
    I think it's fairly safe to claim it's an issue with Gaia at this point. A bug/issue has been opened by support, but no idea what the status is on it.

    1
    Comment actions Permalink
  • Avatar
    ktdoan98

    So why would Gaia think I would pay more than double to renew my subscription for this app?!

    1
    Comment actions Permalink
  • Avatar
    Ozarks Walkabout

    Just another vote for there is an issue here ... It only seems to start tracking accurately after I check where I am. Thereafter, it keeps tracking accurately.

    0
    Comment actions Permalink
  • Avatar
    bill.landman.2

    Ozark,
    That's been my experience, too.

    Does anyone know if Gaia monitors this Help Center? It would be nice to know if we can expect a fix (or not)

    0
    Comment actions Permalink
  • Avatar
    gosebubbe

    @JacksonBill Not sure if they monitor, but in my initial contact with support, they did state that a bug was filed. No idea what the state of it is though.

    0
    Comment actions Permalink
  • Avatar
    bill.landman.2

    Gosebubbe,
    Thanks. Fingers crossed

    0
    Comment actions Permalink
  • Avatar
    philip

    Been experiencing the same on iOS.  One cause is that Apple doesn't understand the meaning of the word "Always" and will turn off GAIA's background access to the GPS every few weeks unless you  press the "Always Allow" button yet again.  This has killed a track or two of mine.  

    I'm now running a Garmin watch and RWGPS concurrently with GAIA hoping one of the three won't bomb, die, stop working, lose permissions, whatever and I can record a track successfully.

    0
    Comment actions Permalink
  • Avatar
    5stone

    Just wanted to chime in that I've been experiencing the same thing. On routes I've ridden regularly, Gaia used to track accurately (iOS app) but now on the same routes, the tracks are always off. I'll get the straight line issue described earlier, but I'm also having the track "bulge" out, often around turns before it snaps back a couple hundred meters later. Very annoying. I use a Garmin Fenix and at this point, I delete the Gaia track post ride and just import the accurate Garmin track into the Gaia web browser interface and use that to log my rides. I've been using Gaia for years and agree this is a recent issue. 

    1
    Comment actions Permalink
  • Avatar
    5stone

    Still happening. Isn't providing an accurate GPS location and track pretty much the foundation of the app? But instead of fixing this issue, we get UI changes to the route creation tool (no new functionality, just a horizontal layout change). 

    0
    Comment actions Permalink

Please sign in to leave a comment.